An error occurred in nmInstall? Json how to solve?

  node.js, question

NmInstall error

nmp install

E:\counter>npm install
 npm WARN package.json redux-counter-example@0.0.0 No README data
 npm WARN unmet dependency E:\counter\node_modules\node-libs-browser\node_modules\url requires punycode@'1.3.2' but will load
 npm WARN unmet dependency E:\counter\node_modules\node-libs-browser\node_modules\punycode,
 npm WARN unmet dependency which is version 1.4.1
 npm WARN unmet dependency E:\counter\node_modules\jsdom\node_modules\acorn-globals requires acorn@'^2.1.0' but will load
 npm WARN unmet dependency E:\counter\node_modules\jsdom\node_modules\acorn,
 npm WARN unmet dependency which is version 1.2.2
 npm WARN unmet dependency E:\counter\node_modules\jsdom\node_modules\request requires tough-cookie@'~2.2.0' but will load
 npm WARN unmet dependency E:\counter\node_modules\jsdom\node_modules\tough-cookie,
 npm WARN unmet dependency which is version 1.2.0
 npm WARN unmet dependency E:\counter\node_modules\mocha\node_modules\jade requires commander@'0.6.1' but will load
 npm WARN unmet dependency E:\counter\node_modules\mocha\node_modules\commander,
 npm WARN unmet dependency which is version 2.3.0
 npm WARN unmet dependency E:\counter\node_modules\mocha\node_modules\jade requires mkdirp@'0.3.0' but will load
 npm WARN unmet dependency E:\counter\node_modules\mocha\node_modules\mkdirp,
 npm WARN unmet dependency which is version 0.5.1

https://www.google.com/search? Q=npm plus WARN …

Google has passed and there is no answer.

Wang Dashen

E:\counter>npm -v
2.14.20
E:\counter>node -v
v4.4.1

Warning, just ignore it. . .