Compatibility Issues of node after Migrating from os x to Ubuntu

  node.js, question

Xxhash is required for the code.
From os x deployment to Ubuntu, it seems that this package introduces fsevents. This stuff can only be packaged under OS X. How can this situation be solved?

npm ERR!  notsup Unsupported
 npm ERR!  notsup Not compatible with your operating system or architecture: fsevents@1.0.9
 npm ERR!  notsup Valid OS:    darwin
 npm ERR!  notsup Valid Arch:  any
 npm ERR!  notsup Actual OS:   linux
 npm ERR!  notsup Actual Arch: x64

Did you pack node_modules under os x and use them under linux?
This kind of situation is generally dependent on the library to have C add-on plug-ins. Do not pack the node_modules directory. Under linux, run npm i directly in the program directory and recompile the C add-on module during installation.