Compatibility of node Versions

  node.js, question

How compatible are the different versions of node and where can I view the features of different versions?
Is the version of npm based on the version of node?

Previous versions of node were very confusing, but compatibility basically followed es, so there was nothing special to pay attention to except bug fixing between several versions.
Now that the LTS is released, there is no need to follow the version specifically, basically, es6 has different levels of support.
Npm has its own version. If node downloads the update through its official website, it will bring its own new version of npm.
However, if updated by a package manager such as n, only node may be updated regardless of npm
Fortunately, npm can update itself