Is pm2 incompatible with node@4.5.0 and will pm2 be prompted not to have this command every time the node version is switched

  node.js, question

Today, I upgraded node from 4.4.7 to 4.5.0. I found that pm2 is not available, and can be started. It shows that the current file is started and monitored, but the browser cannot open the page.
After cutting back version 4.4.7, everything is normal. This is a problem.
The second question is:
Why does pm2 prompt no such command after switching the node version each time? Then I have to reinstall it again.
Do you have any friends who meet these two problems?

If you use nvm, npm install is for node version, and different versions of package are not shared.