Is there a bug in npmpdate-g under windows?

  node.js, question

Intermittent convulsions, found several times, clearly npm has a new version, but how to update all don’t download the new version.
Npm install xxx@latest -g is required to download the new version.

Looking at the npm version, npm update -g is only supported above 2.6.1.
The way to update the npm version is
npm install npm@latest -g

p.s.
See if there are updates to execute the command.
local package: npm outdated
global package: npm outdated -g –depth=0