Is there a problem installing Hexo under Ubuntu16.04?

  node.js, question

The notebook computer is equipped with Ubuntu16.04 and wants to migrate the blog of hexo on another computer. However, error occurred during the installation of hexo and the installation failed.
I installed nodejs and npm first, and then ordered hexo to be installed:

$sudo npm install -g hexo-cli

The following error occurred:
图片描述

I began to think that nodejs or npm installation has a problem. Reinstallation or failure.
I suspect that Ubuntu16.04 is compatible with hexo. Have you encountered this problem? How to solve it?

hexo-cliIt’s just an accidenthexoDependent submodules.
You should install

sudo npm i -g hexo