Js encountered an error updating the version with code.

  node.js, question

npm ERR! Windows_NT 10.0.10586
npm ERR! argv “D:\Program Files\nodejs\node.exe” “D:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “install” “-g” “n”
npm ERR! node v4.4.3
npm ERR! npm v2.15.1
npm ERR! code EBADPLATFORM

npm ERR! notsup Unsupported
npm ERR! notsup Not compatible with your operating system or architecture: n@2.1.1
npm ERR! notsup Valid OS: ! win32
npm ERR! notsup Valid Arch: any
npm ERR! notsup Actual OS: win32
npm ERR! notsup Actual Arch: x64

nWindows is not supported.

https://github.com/tj/n#additional-details