Just installed the latest node, npm install reported this error! Ask ndoe to answer! ! !

  node.js, question

clipboard.png
Both npm -v and node-v can be printed out.
But npm install reports an error!

  1. runnpm config get proxyLook what you got.

  2. If the above return is not empty,npm config set proxy nullOr ..npm config delete proxy, by the way, turn off https agent alsonpm config set https-proxy null, certificate problem, turn off the certificate checknpm config set strict-ssl false, of course, you don’t have to type all the above commands, according to the error message prompt, choose the corresponding solution, and then try again

  3. If the command of 1 is empty, check if there is HTTP_PROXY in your environment variable

  4. Is there a global agent