Npm install s reported an error.

  node.js, question

npm ERR! Windows_NT 6.1.7601
npm ERR! argv “d:\Program Files\nodejs\node.exe” “d:\Program Files\nodejs\
node_modules\npm\bin\npm-cli.js” “install” “bootstrap-datetimepicker” “–save
-dev”
npm ERR! node v0.12.4
npm ERR! npm v2.11.1
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package grunt does not satisfy its siblings’ peerDepend
encies requirements!
npm ERR! peerinvalid Peer grunt-contrib-nodeunit@0.3.3 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-watch@0.6.1 wants grunt@~0.4.0
npm ERR! peerinvalid Peer grunt-contrib-jshint@0.10.0 wants grunt@~0.4.0

npm ERR! Please include the following file with any support request:
npm ERR! d:\home\jngongzuo\slackend-wei-jail\ui\npm-debug.log

This problem has been solved. First of all, there is a hint in warn that bootstrap uses grunt to build his building tools in conflict, so I uninstalled bootstrap and reinstalled it. If there is a good answer, please update it in time.