npm install warn

  node.js, question

When learning postcss, the following warning appears:
1. What do these warnings mean and why?
2. How to solve this problem?
3. postcss-cli is still installed after several warnings. Is the installation complete or incomplete? Does the previous warnings affect the installed version?
C:\Users\Cherry>npm install -g postcss-cli
npm WARN optional dep failed, continuing fsevents@1.0.8
C:\Users\Cherry\AppData\Roaming\npm\postcss -> C:\Users\Cherry\AppData\Roaming\npm\node_modules\postcss-cli\bin\postcss
npm WARN unmet dependency C:\Users\Cherry\AppData\Roaming\npm\node_modules\cordova\node_modules\cordova-lib requires nopt@’^3.0.6′ but will load
npm WARN unmet dependency C:\Users\Cherry\AppData\Roaming\npm\node_modules\cordova\node_modules\nopt,
npm WARN unmet dependency which is version 3.0.1
postcss-cli@2.5.1 C:\Users\Cherry\AppData\Roaming\npm\node_modules\postcss-cli
├── neo-async@1.7.4
├── read-file-stdin@0.2.1 (gather-stream@1.0.0)
├── resolve@1.1.7
├── yargs@3.32.0 (camelcase@2.1.0, decamelize@1.2.0, window-size@0.1.4, y18n@3.2.0, os-locale@1.4.0, cliui@3.1.0, string-width@1.0.1)
├── postcss@5.0.19 (js-base64@2.1.9, supports-color@3.1.2, source-map@0.5.3)
├── globby@3.0.1 (pify@2.3.0, arrify@1.0.1, object-assign@4.0.1, pinkie-promise@1.0.0, array-union@1.0.1, glob@5.0.15)
└── chokidar@1.4.3 (path-is-absolute@1.0.0, inherits@2.0.1, glob-parent@2.0.0, async-each@1.0.0, is-binary-path@1.0.1, is-glob@2.0.1, readdirp@2.0.0, anymatch@1.3.0)

Under Windows, try opening cmd with administrator privileges before using npm’s global installation (npm install -g)


The warning does not affect the use of the package.fseventsIt is something OS X needs, so it is an unnecessary dependency package, so it was not installed successfully.