Npm reported an error after upgrading. How can I solve it?

  node.js, question

After using brew to upgrade node, npm has been reporting more errors. How do you solve it?

Note: node has been reinstalled and has no effect.

When I execute the following command

npm ls -g

Prompt for the following error

npm ERR!  invalid: casperjs@1.1.0-beta3 /usr/local/lib/node_modules/casperjs
 npm ERR!  missing: async@^0.9.0, required by ionic@1.5.5
 npm ERR!  missing: cheerio@^0.19.0, required by ionic@1.5.5
 npm ERR!  missing: cli-table@^0.3.1, required by ionic@1.5.5
 npm ERR!  missing: colors@0.6.2, required by ionic@1.5.5
 npm ERR!  missing: connect@3.1.1, required by ionic@1.5.5
 npm ERR!  missing: connect-livereload@0.5.2, required by ionic@1.5.5
 npm ERR!  missing: crc@3.2.1, required by ionic@1.5.5
 npm ERR!  missing: cross-spawn@0.2.3, required by ionic@1.5.5
 npm ERR!  missing: event-stream@3.0.x, required by ionic@1.5.5
 npm ERR!  missing: finalhandler@0.2.0, required by ionic@1.5.5
 npm ERR!  missing: form-data@0.1.4, required by ionic@1.5.5
 npm ERR!  missing: gulp@3.8.8, required by ionic@1.5.5
 npm ERR!  missing: ionic-app-lib@0.2.2, required by ionic@1.5.5
 npm ERR!  missing: ncp@0.4.2, required by ionic@1.5.5
 npm ERR!  missing: opbeat-ionic@^1.1.3, required by ionic@1.5.5
 npm ERR!  missing: open@0.0.5, required by ionic@1.5.5
 npm ERR!  missing: optimist@0.6.0, required by ionic@1.5.5
 npm ERR!  missing: progress@1.1.7, required by ionic@1.5.5
 npm ERR!  missing: prompt@0.2.12, required by ionic@1.5.5
 npm ERR!  missing: proxy-middleware@^0.7.0, required by ionic@1.5.5
 npm ERR!  missing: q@1.0.1, required by ionic@1.5.5
 npm ERR!  missing: request@2.51.0, required by ionic@1.5.5
 npm ERR!  missing: semver@^4.2.0, required by ionic@1.5.5
 npm ERR!  missing: serve-static@1.7.1, required by ionic@1.5.5
 npm ERR!  missing: shelljs@0.2.6, required by ionic@1.5.5
 npm ERR!  missing: tiny-lr-fork@0.0.5, required by ionic@1.5.5
 npm ERR!  missing: underscore@~1.7.0, required by ionic@1.5.5
 npm ERR!  missing: unzip@0.1.9, required by ionic@1.5.5
 npm ERR!  missing: vinyl-fs@0.3.7, required by ionic@1.5.5
 npm ERR!  missing: xml2js@0.4.4, required by ionic@1.5.5
 npm ERR!  invalid: npm@2.11.2 /usr/local/lib/node_modules/npm
 npm ERR!  missing: glob@^4.4.2, required by rimraf@2.3.4

Can direct npmpupdate be upgraded soon?