The packages required for dependencies of modules installed by node.js npm are under the node_modules folder of the project.

  node.js, question

As shown in the figure图片描述

This makes obsessive-compulsive disorder unbearable.
This should have been the case before.
图片描述
The modules required by express are in the express private module.

How can help turn back to the original
(node was upgraded once and now it is 6.2.0. It used to be 0.4.1 npm and now it is version 3.8.9)

New versions of npm have all changed to this way, thus solving the problem caused by too long path.
Only the old version of npm can be used to get the original form.