What’s wrong with the webpack’s extratextplugin for webpack?

  node.js, question

Official examples, all can’t run?

const ExtractTextPlugin = require("extract-text-webpack-plugin");
 module.exports = {
 entry: "./src/js/app.js",
 output: {
 path: __dirname,
 filename: "bundle.js"
 },
 module: {
 loaders: [
 { test: /\.css$/, loader: ExtractTextPlugin.extract("style-loader", "css-loader") },
 { test: /\.styl$/, loader: ExtractTextPlugin.extract("style-loader", "css-loader","stylus-loader") },
 { test: /\.js$/, exclude: /node_modules/, loader: "babel-loader" }
 bracket
 },
 plugins: [
 new ExtractTextPlugin("styles.css")
 bracket
 };

Error message:
图片描述

Do you have any webpack/lib/removeddo.js file under your node_modules?

If not, npm install or directly delete all node_modules, and then try installing again.