When installing grunt plug-in, report this error?

  node.js, question

What does this report mean?
npm ERR! Linux 2.6.18-274.el5
npm ERR! argv “/usr/local/node/bin/node” “/usr/bin/npm” “install” “grunt-curl” “–save-dev”
npm ERR! node v4.5.0
npm ERR! npm v2.15.9
npm ERR! code EPEERINVALID

npm ERR! peerinvalid The package grunt@1.0.1 does not satisfy its siblings’ peerDependencies requirements!
npm ERR! peerinvalid Peer grunt-remove@0.1.0 wants grunt@~0.4.1
npm ERR! peerinvalid Peer grunt-exec@1.0.0 wants grunt@>=0.4
npm ERR! peerinvalid Peer grunt-contrib-concat@1.0.1 wants grunt@>=0.4.0
npm ERR! peerinvalid Peer grunt-shell@1.3.1 wants grunt@>=0.4.0

npm ERR! Please include the following file with any support request:
npm ERR! /data/iyong/project/web/itempc/build/npm-debug.log

Sudo npm i xxx -g try