After mac upgrade, compile scss with koala to report an error

  question, ruby
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs': Could not find 'sass' (>= 0) among 16 total gem(s) (Gem::LoadError)
 Checked in 'GEM_PATH=/Users/sunling/.gem/ruby/2.3.0:/Library/Ruby/Gems/2.3.0:/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/gems/2.3.0', execute `gem env` for more information
 from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/dependency.rb:328:in `to_spec'
 from /System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_gem.rb:65:in `gem'
 from /Volumes/Koala/Koala.app/Contents/Resources/app.nw/bin/sass:17:in `
 '

After the mac was upgraded to 10.13, koala was downloaded again and scss was compiled again to report an error

Hello, this help me resolve the problem for me.

Open Terminal
Install Homebrew:

 ruby -e “$(curl -fsSLhttps://raw.githubusercontent …)”
Do not close Terminal, open Mac Appstore and check Update, install all XCode Command Line Tools updates OR in my case, XCode Command Line Tools started install automaticly throught Terminal right after step 2.
Back to Terminal
Install Ruby:
 
brew install rbenv ruby-build
Install SASS gem: 

sudo gem install -n /usr/local/bin sass
After this steps, everything works fine and I can compilate again with Koala or in Dreamweaver.

I found a solution on github.

Step 1: Run ruby -e “$(curl -fsSL) in the commandhttps://raw.githubusercontent …)”

Step 2: Open your xcode to update

Step 3: run brew installrbenvrby-build in the command

Step 4: run sudogeminstall-n/usr/local/binsass in the command

Koala will compile normally after completion.