Npm found inconsistent versions?

  git, question

clipboard.png

clipboard.png

clipboard.png

Why is package’s plug-in version number different from npm’s? ? ? ?
Old iron, this is how fat thing > _ <

Because of yourspackage.jsonThe version numbers written inside are all^At the beginning, that is, during installation, the policy is to use the latest version as much as possible before the next big version.
Take vuex for example^2.1.1 := >=2.1.1 <3.0.0