Ruby installation

  question, ruby

I would like to ask you a question. Everything in my company’s computer can be installed normally and smoothly, but when I came back, I used my notebook to install ruby first and copied back the same installation package, which was successfully installed. Enter the command ruby -v to get:
ruby 2.3.0p0 (2015-12-25 revision 53290) [x64-mingw32]
However, when I enter the command gem install sass, I always report an error and the prompt is:
<internal:gem_prelude>:4:in `require’: cannot load such file — rubygems.rb (LoadError)
from <internal:gem_prelude>:4:in `<internal:gem_prelude>’
So I searched for all kinds of solutions on the Internet, but still failed to solve him. I entered the command gem -v and the same prompt appeared. Has anyone encountered the same problem? How is it solved?

pacman -S ruby