Ruby ran resque-web project reporting an error.

  question, ruby
It's okay in my local area, but the other server just can't.  The error is reported as follows: Online etc
 /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:2288:in `raise_if_conflicts': Unable to activate sinatra-1.4.7, because rack-2.0.1 conflicts with rack (~> 1.5) (Gem::ConflictError)
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/specification.rb:1408:in `activate'
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems.rb:220:in `rescue in try_activate'
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems.rb:213:in `try_activate'
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:126:in `rescue in require'
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:40:in `require'
 from /data/www/syh/resque/resque/lib/resque/server.rb:1:in `<top (required)>'
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'
 from /usr/local/lib/ruby/site_ruby/2.3.0/rubygems/core_ext/kernel_require.rb:55:in `require'

Gem rake’s version is not correct, it has already prompted you to use 2.0.1.