Vim compilation supports python3 and lua issues

  question, vim

When I installed vim through source code compilation, I added the following parameters during compilation
./configure \

--prefix=/usr \
 --with-features=huge \
 --enable-multibyte \
 --enable-cscope=yes \
 --enable-perlinterp=yes \
 --enable-rubyinterp=yes \
 --enable-luainterp=yes \
 --enable-python3interp=yes \
 --enable-fontset=yes \
 --enable-terminal=yes \
 --enable-largefile \
 --with-lua-prefix=/usr/local/bin \
 --with-luajit \
 --with-python3-command=python \
 --with-python3-config-dir=/usr/local/bin/python3-config \
 --with-ruby-command=ruby \
 --with-compiledby=$USER \
 --disable-gui \
 --disable-netbeans \

According to the instructions in the document, after using sudo make && make install, open vim,: version can see python3 and lua should be preceded by a+sign, but why is mine still-

clipboard.png

May I know where this configuration is wrong, or where the system needs to be changed? My mac
I have already installed python3 and lua:

clipboard.png

To add lua and python3 support at compile time, the system needs a development library of lua and python3.

If you are using macos, it is recommended that you use homebrew to install it.