When installing emmet with vundle, an error was reported. internet search said that vundle should be installed manually, but after I installed vundle according to the official documents, it was still not possible.

  question, vim

clipboard.png

clipboard.png

On the right is the configuration of _vimrc, on the left is the vundle plug-in downloaded from github, and the path is above the address bar.

Another thing is to open gvim and often pop up a message. I don’t know if it has anything to do with this.

clipboard.png

It is common knowledge that programs should not be placed in Chinese directories.

Vundle.vimIt is true that temporary file-related errors occasionally occur on Windows

I haven’t used it for a long time.VundleYes, becauseVundleMultithreading is not supported.
If you have just contacted Vim’s package manager, it is recommended to usevim-plug
If vim 8.0 can pass the native features+jobRealize multithreading
Vim 7.4 can also be passed+python/+python3/+rubyAnd other ways to achieve multithreading

According to your habit, vim configuration is placed in the program directory. I’ll introduce you to the simple configuration method.

Run at the command prompt:

Cd /d E:\ program \vim
 git clone  https://github.com/junegunn/vim-plug.git
 mkdir /p vimfiles\autoload
 move vim-plug\plug.vim vimfiles\autoload\
 del /s /q vim-plug

The following is the vimrc configuration

"Set the number of threads
 let g:plug_threads = 8
 call plug#begin(expand('$VIM/vimfiles/bundle'))
 
 Plug 'mattn/emmet-vim'
 call plug#end()
 
 filetype indent plugin on
 syntax enable

The following are plug-in commands:

Install plug-ins:PlugInstall
Update plug-in:PlugUpdate
Update plug itself:PlugUpgrade
View plug-in status:PlugStatus

No, I’ll say JJ

On the lower right are three bookmarks I specially added mark.

图片描述