Docker Error in Making node Mirror to Install pm2? ?

  docker, question

Dockerfile

FROM node:8.9.1
 
 
 RUN npm install -g cnpm  --registry=https://registry.npm.taobao.org
 RUN cnpm install -g pm2@next
 
 RUN cnpm install
 # Modify Time Zone
 RUN cp /usr/share/zoneinfo/Asia/Shanghai /etc/localtime
 
 RUN mkdir -p /usr/src/app
 WORKDIR /usr/src/app
 
 CMD [ "pm2-docker", "start", "pm2.json" ]

simple enough!

Problem

At the time of the final build,

Platform unsupported chocidar @ 1.7.0holmium?  fsevents@^1.0.0 Package require os(darwin) not compatible with your platform(linux)
 Traceback (most recent call last):
 File "docker-compose", line 6, in <module>
 File "compose\cli\main.py", line 68, in main
 File "compose\cli\main.py", line 121, in perform_command
 File "compose\cli\main.py", line 938, in up
 File "compose\project.py", line 430, in up
 File "compose\service.py", line 317, in ensure_image_exists
 File "compose\service.py", line 922, in build
 File "compose\progress_stream.py", line 23, in stream_output
 File "compose\progress_stream.py", line 90, in print_output_event
 File "codecs.py", line 370, in write
 File "site-packages\colorama\ansitowin32.py", line 40, in write
 File "site-packages\colorama\ansitowin32.py", line 141, in write
 File "site-packages\colorama\ansitowin32.py", line 166, in write_and_convert
 File "site-packages\colorama\ansitowin32.py", line 174, in write_plain_text
 IOError: [Errno 0] Error
 Failed to execute script docker-compose

anyone good advice? ?

Platform unsupported chocidar @ 1.7.0holmium? fsevents@^1.0.0 Package require os(darwin) not compatible with your platform(linux)

This is an ignored error. fsevents is an optional dependency, is only used on macOS and not on Windows or Linux. You can simply ignore it!